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Introduction

This document describes how VPN Tracker can be used to establish a connection between a Macintosh running Mac OS X
and a WatchGuard Firebox VPN firewall.

The WatchGuard Firebox gateway is configured as a router connecting a company LAN to the Internet.

This paper is only a supplement to, not a replacement for, the instructions that have been included with your WatchGuard
Firebox. Please be sure to read those instructions and understand them before starting.

EQUINUX SHALL HAVE ABSOLUTELY NO LIABILITY FOR ANY DIRECT OR INDIRECT, SPECIAL OR OTHER CONSEQUENTIAL
DAMAGES IN CONNECTION WITH THE USE OF THE HOW-TO OR ANY CHANGE TO THE ROUTER GENERALLY, INCLUDING
WITHOUT LIMITATION, ANY LOST PROFITS, BUSINESS, OR DATA, EVEN IF EQUINUX HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES.



Prerequisites

First you have to make sure to use a recent Fireware firmware version. The latest release for your WatchGuard Firebox
firewall can be obtained from https://www.watchguard.com/archive/softwarecenter.asp/

For this document, Fireware firmware version 8.2.1 has been used.

Please note: VPN Tracker has been only been tested with the WatchGuard Firebox X series and the above firmware version.
You will need one VPN Tracker Personal Edition license for each Mac connecting to the WatchGuard Firebox.

We recommend one VPN Tracker Professional Edition for the administrator’s Mac in order to export configuration files to
the clients. VPN Tracker is compatible with Mac OS X version 10.2.5+, 10.3 and 10.4.1+


https://www.watchguard.com/archive/softwarecenter.asp
https://www.watchguard.com/archive/softwarecenter.asp

Scenario

In our example, we need to connect an employee's Mac Book in San Francisco to an office in New York. The following
diagram illustrates this scenario:

—

The MacBook is directly connected to the Internet and has a public IP address, assigned by an ISP.

The office's VPN gateway is also connected to the Internet and can be accessed via an static IP address. The VPN gateway

also has a second interface which is connected to the internal office network. In our example, the office network has the
IP range 192.168.1.0/24.

A VPN tunnel will be established between the public interfaces in San Francisco and New York. Once the VPN tunnel is up,
San Francisco can access the office network behind the VPN gateway.

7



Please note that the connection from a MacBook at home to an office network is just one possible scenario. The
instructions also apply to connections from a desktop computer or notebook in your office to a VPN gateway at home or
at another office. Please adapt the term "office network", which is used throughout this manual, to your scenario.



Task 1 - Configure your WatchGuard Firebox

This section describes the configuration of your WatchGuard Firebox. The configuration will be created
with the “Fireware Policy Manager”.

TIP  When setting up a VPN, you'll have to handle a couple of parameters. Those parameters are marked with red dots with little
numbers in it. Throughout the setup we will point back to those parameters.

Step 1 - Add a new Branch Office Gateway

7§ FireBox.xml * - Fireware Policy Manager =10l =]

H u . "
File Edit “iew Setup Metwork YPN  Tasks  Help } ClICk On BranCh Ofﬂce GateWayS

|2|n[=]u] v]+]| x| ul“lﬁﬂl\“‘“" 8|z|afm » Click on “Add” in the “Gateways” dialog.

Firewsll Branch Office VPR | Mokile User YPN |

Eranch Office Gateways

Show: (4l Tunrels il




New Gateway

Gatevvay Marne: varrtracker

Remdte Gateway Setting

ateay IP: IAny

|

D Teypaec |Dnmain hatne

x| vantrac:ker (1)

IC Ty |IP Address

| fesaza

¥ Pre-Shared Key Isecretkey [2)

Phasel Seftings

Avthentication: ISHA‘I 'I
Encryption: ISDES 'I

hade: IMain 'I
Ok | Cancel

=l

Help |

» Gateway Name: Enter an unique name for the VPN
gateway (e.g. vpntracker).

» Remote Gateway Settings:
+ Gateway IP: Select Any.

+ ID Type: Select Domain Name and enter an unique
name (e.g vpntracker). €

» Local Settings:

+ ID Type: Select the IP address of the untrusted
interface from your WatchGuard Firebox.

» Pre-shared Key: Enter a secure password for the
connection (e.g. secretkey). Q

» Leave the Phase1 Settings untouched.

» Click on Ok, when you're done.
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Step 2 - Create a Branch Office Tunnel

7§ FireBox.kml * - Fireware Policy Manager =101 x|

Fie Edt View Setup Metwork VPN Tasks Help » Click on“Branch Office” Tunnels.

|2la=u]v]+]|x] e ufs |ﬂJ%_|\ﬁ|E|90|I 2| ?l » Click on“Add..." in the “Branch Office IPsec Tunnels”
Firewall Branch OmceWNannna User VPNI )
| interface.

ram:h Office Tunnels |
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Tunnel Matne vpr‘drackertunnel

Gmeway@_l _I

~PhazeZ Settings

Proposal  [Esp-aES-SHA Rd| |:=“| F_‘i|
¥ PFS  |Diffie-Hellman Groupt =] Advanced...l
~Addreszes
Local | oir | Remote ( Add.
Edlf..

Remove |

Cancel

Help

» Tunnel Name: Enter an unique name for the VPN tunnel
(e.g. vpntracker tunnel)

» Gateway: Select the previously created VPN gateway
(vpntracker)

» Leave the Phase2 Settings untouched.

» Create a new addresses entry by clicking on “Add..."
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Local-Remote Pair Settings X|| » Local: Enter the network address, which should be
reached through the VPN tunnel. (e.g. 192.168.1.0/24) €)

Lacal a92.168.1.0i24 M

<|1\ u —I » Remote: Enter an unique virtual IP address for the VPN
Remate: M Tracker client. (e.g. 10.1.2.3/32). O
Direction:  Local I-:===:- 'I Remote > Click on"OK™

MAT Settings

[ AmNat | _I

[~ DRAT
Ok [_:! Cancel | Help |

TIP  The virtual IP address in the remote field must not be within the same range of the local network or the clients real home
network. You later need to enter this IP address as “Local Address” in your VPN Tracker configuration.
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|y Click on“OK” in the “New Tunnel” dialog.

Tunnel Marne: var‘drackertunnel

Gateway: var‘dracker LI EEIEI

~PhazeZ Settings

Proposal  [Esp-aES-SHA Rd| |:=‘j| D.|
¥ PFS  |Diffie-Hellman Groupt |
~Addreszes
Local I Dir I Remate
192 1681 0/24 ===+ 10123632

Remove |

Ok %l Cancel Help
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Task 2 - Configure VPN Tracker

This section describes the configuration of VPN Tracker for your WatchGuard Firebox router.

Step 1 - Create a new Connection

006 e — * Clickon“New”in the VPN Tracker main window.
@ =8
k- Edit Duplicate Delete Export Activity Log
Connection Status

VPN service is not running

™ Smart vPN Stop VPN E
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Step 2 - Connection Settings

060 S » Vendor: Select the vendor (WatchGuard)

% » Model: Select your VPN router model with (e.g.
WatchGuard Firebox X2500 (Fireware))

Connection:  Mew York]

» Make sure to enable “Initiate connection from this
end”

{ Connection | Network — Authentication Identifiers DNS

Vendor: | WatchGuard s

Model: WatchGuard Firebox X2500

WatchCuard Firebox X2500 (Fireware) m

WatchGuard Firebox X500 i
WatchCuard Firebox X500 (Fireware) v
5 - "_ How-To... _\'

Connection Options: @ Initiate connection from this end
"1 Connect only when needed
" Disable NAT Traversal

__ Client Provisioning

Protocol:  Mode Config v

:_r._!“: Click the lock to prevent further changes.

( Cancel ) ( oK )

TIP  The pre-defined VPN Tracker connection for the WatchGuard Firebox is based on the default settings for the WatchGuard

Firebox X series with Fireware firmware versions. If you or the administrator changed any of the settings while configuring
the device, you might have to adjust the connection type in VPN Tracker by double-clicking on the model.
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Step 3 - Network Settings
eoeo

Connection: New York

Connection:  New York]| %

! Connection | Network | Authentication  Identifiers  DNS -

Topology: = Host to Network | :!

Metwork Port: = Automatic f

VPN Gateway AddressC_169.1.2.3

Local Address 10.1.2.3 @ optional
Remote Network/Mask< 192.168.1.0 € |/ 255.255.255.0 L+

@. Click the lock to prevent further changes.

p =
( Cancel ) € 0K

» VPN Server Address: Enter the public IP address of
your VPN Gateway (e.g. 169.1.2.3)

» Local Address: Enter the virtual IP address, you've
chosen in your WatchGuard configuration (e.g.
101.2.3). O

» Remote Network/Mask: Enter the network address
and netmask of your office network. (3)
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Step 4 - Authentication Settings

60 Connection: New York

re-shared key" -
secretkey| @ %
[ Hide typi

—— Col () Enter key when establishing connection NS —

| St | e P J
The key will not be saved on disk.
i

( Cancel )M

1 Enable Extended Authentication (XAUTH)

@ Click the lock to prevent further changes.

Cancel OK

» Pre-shared key: Enter the Pre-shared key you used
earlier when configuring the WatchGuard Firebox.

(2]
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Step 5 - Identifiers Settings

®O N Connection: New York
Connection:  New York] %
— | Connection  Network  Authentication | Identifiers | DNS

Local Identifier: () Local endpoint IP address

@ FQDN

Remote Identifier: ®) Remote endpoint IP address

@ vpntracker @

") Remote certificate

3
W

(ar]

"1 Verify remote identifier

@ Click the lock to prevent further changes.

( Cancel ) E—BK—)

» Local Identifier: Enter the domain name you used
when configuring the WatchGuard Firebox. @
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Task 3 - Check the VPN connection

This section explains how to start and test your VPN connection.

It's time to go out!

You will not be able to test and use your VPN connection from within your office network. In order to test your connection, you'll

need to connect from a different location. That's why it's now time to go out. Take your MacBook Pro and have a coffee at your
favorite Internet cafe or go visit a friend.

Test your connection
To test if everything is setup correctly please follow the steps below:
» Get access to the Internet

» Make sure the Internet connection is working; open your Internet browser and try to connect to
http://www.equinux.com

» Start VPN Tracker if it's not already running

20
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eoe VPN Tracker

— * Select the connection you configured for your
~ 7 - WatchGuard Firebox device

A [ o EH .

MNew Edit Duplicate Delete Export Activity  Log » Hit the Start VPN button

Connection

Status
M % Mew York

VPN service is not running

™ Smart VPN Stop VPN @
y
006 S — * Ifthelight turns red after a few seconds, then
X T, Px [ N - please read the Troubleshooting section on the
2 4 2| .
2 D.*’ D—, 8 A @ - next page
New | Edit Duplicate Delete Export Activity Log

Connection Status

Connection to 192.168.13.0/255.255.255.0 s
established.

» If the light turns green, that means you've
successfully established a connection

.~ New York

Congratulations! You did it!

VPN service is running
™ Smart VPN

( Stop VPN ) (€ Restart VPN

v
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Troubleshooting

| don’t get a green light in the VPN Tracker main window

» Make sure that your computer is not connected directly to the office network you want to connect to.

» Make sure, that the Identifier and the Pre-shared key you've entered in the router configuration match the settings you entered in
VPN Tracker.

» Verify that the public IP address you entered in VPN Tracker matches the public IP address of your router.

» Download our sample configuration and connect to our test device at http://www.vpntracker.com/connectiontest/
« If the test connection cannot be established: Make sure, that the internet connection is working and verify that your local
router is not blocking any connection attempts.

+ If the test connection is established successfully: Your internet connection is working and does not block VPN connections.
Please check the log file of your WatchGuard Firebox for error messages.

» If you're still having issues with your connection, please create some screenshots of your settings on both ends, gather the log files
and send them over to our support team via http://www.equinux.com/us/products/vpntracker/contactus.html.
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What's next?

This section explains how to use your VPN connection.

Introduction

As the VPN connection has now been established, you should be able to access most of the resources in your office network.

Known Limitations
There are some limitations of a VPN connection compared to a direct connection to a office network.
» Bonjour: As Bonjour Chat is not supported over a VPN tunnel, you'll need to use iChat server in order to chat remotely.

» Browsing the network: You can't “browse” the remote network as you're normally used to. You need to connect to each machine
manually, as described on the next page.
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Accessing Files

To access files in your office network, just follow the steps below:

.'. Finder

File Edit

View MW Window Help

Back £ |
Forward £
Enclosing Folder Ei|

= Computer T ¥C

4 Home {r3H
 Network T+ #K
@ iDisk 3

# Applications {1 3A
[ utilities
Recent Folders

Co to Folder...

Connect to 5erver.. [

» Go to the Finder application

» In the menu bar, click on Go->Connect To Server...
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eoo Connect to Server » Enter the IP address of the machine you want to connect to.

In our example network this would be the IP address
192.168.1.2 + O 192.168.1.2

Server Address:

Favorite servers: » Click on the Connect button

» Enter your Username and Password to access the files

Remaove (" Browse ) f Connect }

Vi

TIP  When connecting to a Windows fileserver, you'll need to prefix the IP address with “smb://; e.g. “smb://192.168.1.2"
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Accessing a FileMaker Database

To access a database available in your office network, just follow the steps below:
» Start the FileMaker application

@ FileMaker Pro iR Edit View Insert Format » In the menu bar, click on File->Open Remote...

New Database...
Open...

Open Remote...
Open Recent
Close

Define

File Options...
Change Password..

Page Setup..

Print..

mport Records
Export Records...
Save/Send Records As
Send Mail. ..

Save a Copy As..
Recover...

26



Open Remote File > Click on the Add... button

View: | Favorite Hosts l—ii
Hosts Available Files
( Add... g Edit... Remaove
Network File Path: |
Example - fmnet:/hostIPAddress /fileName
P
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Edit Favorite Host

Favorite Settings

Host's Internet Address: 192.168.1.2
(Example - host.domain.com or 192.168.10.0)

Favorite Host's Name: Remote FM Server|

(optional)

File Settings

*) Show all available files for this host
() Show only these files

(= VAl

Enter one file name per line, separated by a carriage return

li Cancel ) H

7

» Enter the IP address of the FileMaker server machine
» Enter a hostname for this machine (optional)

» Click on the Save button
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Open Remote File " » Select a database from the list of Available Files and click

View:  Favorite Hosts =) Open
Hosts Available Files » You are now able to access your FileMaker databases as
Remote FM Server (192.168.1.2) Usual

™\

( Add... )( Edit... )( Remove)

Metwork File Path: fmnet:/192.168.1.2/
Example - fmnet:/hostIPAddress /fileName

Fa

(" Cancel ) Open
i
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Acquire more Licenses

If two or more people need to access your office network via VPN, then you need to acquire more VPN
Tracker licenses.

To get more licenses, please contact your reseller and inquire about,VPN Tracker Personal Edition”.

Or point your browser to http://store.equinux.com and buy additional VPN Tracker Personal Edition Licenses online.
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